Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 20, 2025 - 02:00 EDT
Scheduled
To: ENGAGE Users, Updates Subscribers, and all Williams Lea Managers From: Tami Horvath – Global Director, Technology Solutions and ENGAGE Product Owner; and Mark Cripps – Program Director
REMINDER: ENGAGE will be OUT OF SERVICE on Sunday (July 20)
We wish to remind you that the ENGAGE platform will be inaccessible on Sunday, July 20.
The platform will be temporarily offline for 4 hours for vital preventative maintenance work, crucial for ensuring the platform’s operational stability.
While we make every effort to avoid system downtime, there are times when the type of work being undertaken cannot be completed without putting the ENGAGE platform temporarily out of service.
ENGAGE will be INACCESSIBLE during the following hours (duration: 4 hours):
Sunday, July 20 Time Zone: From: Until: United States (PDT) 11.00 pm 3.00 am United States (CDT) 1.00 am 5.00 am United States (EDT) 2.00 am 6.00 am United Kingdom (BST) 7.00 am 11.00 am India (IST) 11.30 am 3.30 pm Hong Kong (HKT) 2.00 pm 6.00 pm Australia (AEST) 4.00 pm 8.00 pm
Notice will also be given via email and the Engage Status Page here https://status.wl-engage.com/ of any changes to the maintenance schedule.
The full schedule for the ENGAGE Maintenance Sunday Program can be found via the ENGAGE link on Front Door’s Technology Page, and also via the ENGAGE Status Page: https://status.wl-engage.com/
Managers: please encourage your teams to subscribe to the ENGAGE Status Page: https://status.wl-engage.com/ for direct access to all ENGAGE announcements as they are posted.
Any subsequent issues? Should you experience any issues following the scheduled maintenance work, please raise a ticket via the ENGAGE Support Portal or by emailing EngageSupport@williamslea.com.
We appreciate your support.
Posted Jul 15, 2025 - 11:07 EDT
This scheduled maintenance affected: ENGAGE Application, ENGAGE Support Portal, ENGAGE Analytics, Engage Portal (URL: wl-engage.com/Portal) (Service Portal, Analytics), Insights (URL: wl-engage.com/Dashboard) (Dashboard), and Engage Production (URL: wl-engage.com/Production) (API, Production, Quality Assurance).